Issues with setting up VxWorks 7 SDK dev environment


Trying to set up VxWorks 7 SDK for QEMU on Debian 12. There are several issues:

$ sudo apt install build-essential libc6:i386

E: Unable to locate package libc6:i386


$ sudo apt install build-essential libc6-dev

Installing pytfpdlib:

$ sudo apt install python-pip
$ sudo pip install pyftpdlib

… However the following packages replace it: python3-pip
E: Package ‘python-pip’ has no installation candidate


$ sudo apt install python3-pip
$ sudo pip install pyftpdlib

error: externally-managed-environment


$ sudo pipx install pyftpdlib

Finally, starting a local FTP server on port 21 with user “target” and password “vxtarget” and FTP root in the current user’s home can be done as follows

$ sudo python -m pyftpdlib -p 21 -u target -P vxTarget -i -d $HOME

I tried:

sudo python3 -m pyftpdlib -p 21 -u target -P vxTarget -i -d $HOME


/usr/bin/python3: No module named pyftpdlib

This time I am facing a dead end, no resolve can be found.

Any suggestion to solve it?


Hi John,

Running the following commands in a debian:12 container allows me to start the FTP server provided by pyftpdlib.

apt install build-essential libc6-dev
apt install python3-pip
apt install python3-pyftpdlib
python3 -m pyftpdlib -p 21 -u target -P vxTarget -i -d /tmp

As far as I can tell from the pipx documentation, its purpose is to provide isolated environments for each application, so I’m assuming pipx install pyftpdlib did not install pyftpdlib in a globally accessible location.

Using python virtual environments is another valid option for installing pyftpdlib with pip3. You just have to remember to source the environment before using the pyftpdlib module.


1 Like

HI Dan

Thank you, apt install python3-pyftpdlib works good. VxWorks boots (release version 23.03).

To proceed by following Creating and deploying Python applications I got the following:

[vxWorks *]# cd /usr
[vxWorks *]# python3
Launching process 'python3' ...
Process 'python3' (process Id = 0xffff800000363570) launched.
0xffff800000368ca0 (iPython3): RTP 0xffff800000363570 has been deleted due to signal 11.

RTP 0xffff800000363570 has been deleted due to signal 11?


You need run rtpSpStackSize=0x1000000 in the C shell before starting the python interpreter.

-> rtpSpStackSize=0x1000000
rtpSpStackSize = 0xffffffff80c33230: value = 16777216 = 0x1000000

Check this post for more information: VxWorks Software Development Kit (SDK) - #9 by dan.milea



Thank you, it works.
Now I have tried out the foo.vxe and python3 examples. Both of them work.

I wish to dig deeper into VxWorks application development by reading the VxWorks Getting Started, 23.03 web page. As far as I can see most of the links there are not open to public with Error 404.

I tried Visual Studio Code Getting Started and Kernel Application Development.

They seem to be restrictive to non-commerical license holder.

Is there any documentation on application development particularly on VxWorks workbench 4 / VS Code?